微慑信息网

CVE-2008-0301-漏洞详情

CVE-2008-0301
CVSS 7.5
发布时间 :2008-03-11 19:44:00
修订时间 :2008-09-05 00:00:00
NMCOEPS    

[原文]Multiple SQL injection vulnerabilities in Mapbender 2.4.4 allow remote attackers to execute arbitrary SQL commands via the gaz parameter to mod_gazetteer_edit.php and other unspecified vectors.


[CNNVD]Mapbender ‘mod_gazetteer_edit.php’ SQL注入漏洞(CNNVD-200803-175)

        Mapbender存在多个SQL注入漏洞。远程攻击者通过gaz参数到达mod_gazetteer_edit.php 及其他未明向量来执行任意SQL命令。


CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]


CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]


CPE (受影响的平台与产品)

cpe:/a:mapbender:mapbender:2.4.4
cpe:/a:mapbender:mapbender:2.4.3
cpe:/a:mapbender:mapbender:2.4.2
cpe:/a:mapbender:mapbender:2.4
cpe:/a:mapbender:mapbender:2.4.1


OVAL (用于检测的技术细节)

未找到相关OVAL定义


官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0301

(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-0301

(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200803-175

(官方数据源) CNNVD


其它链接及资源

http://xforce.iss.net/xforce/xfdb/41139


(UNKNOWN)  XF  mapbender-gaz-sql-injection(41139)
http://www.securityfocus.com/bid/28193


(UNKNOWN)  BID  28193
http://www.securityfocus.com/archive/1/archive/1/489383/100/0/threaded


(UNKNOWN)  BUGTRAQ  20080311 Advisory: SQL-Injections in Mapbender
http://www.redteam-pentesting.de/advisories/rt-sa-2008-002.php


(UNKNOWN)  MISC  http://www.redteam-pentesting.de/advisories/rt-sa-2008-002.php
http://www.milw0rm.com/exploits/5233


(UNKNOWN)  MILW0RM  5233
http://securityreason.com/securityalert/3728


(UNKNOWN)  SREASON  3728
http://secunia.com/advisories/29329


(VENDOR_ADVISORY)  SECUNIA  29329
http://marc.info/?l=full-disclosure&m=120523564611595&w=2


(UNKNOWN)  FULLDISC  20080311 Advisory: SQL-Injections in Mapbender


漏洞信息

Mapbender ‘mod_gazetteer_edit.php’ SQL注入漏洞
高危 SQL注入
2008-03-11 00:00:00 2008-09-05 00:00:00
远程  
        Mapbender存在多个SQL注入漏洞。远程攻击者通过gaz参数到达mod_gazetteer_edit.php 及其他未明向量来执行任意SQL命令。


公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:


        Mapbender Mapbender 2.4.4


        Mapbender mapbender_2.4.5_rc1.zip


        http://www.mapbender.org/download/mapbender_2.4.5_rc1.zip


漏洞信息 (5233)

Mapbender 2.4.4 (gaz) Remote SQL Injection Vulnerability
(EDBID:5233)
php webapps
2008-03-11 Verified
0 RedTeam Pentesting

N/A

[点击下载]


漏洞信息 (F64488)

rt-sa-2008-002.txt (PacketStormID:F64488)

2008-03-13 00:00:00
 

exploit,remote,sql injection

CVE-2008-0301

[点击下载]

Mapbender version 2.4.4 suffers from a remote SQL injection vulnerability.


漏洞信息


42848
Mapbender mod_gazetteer_edit.php gaz Parameter SQL Injection

Remote / Network Access

Information Disclosure,
Input Manipulation
Loss of Confidentiality,
Loss of Integrity
Upgrade
Exploit Public Vendor Verified,
Vendor Verified,
Coordinated Disclosure


漏洞描述

Mapbender contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'mod_gazetteer_edit.php' script not properly sanitizing user-supplied input to the 'gaz' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.


时间线


2008-03-11

2007-12-14
2008-03-11 2008-03-10


解决方案

Upgrade to version 2.4.5 rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.


相关参考


漏洞作者

Unknown or Incomplete


漏洞信息

Mapbender ‘mod_gazetteer_edit.php’ SQL Injection Vulnerability

Input Validation Error

28193
Yes No
2008-03-11 12:00:00 2008-03-12 06:31:00

RedTeam Pentesting is credited with the discovery of this vulnerability.


受影响的程序版本

Mapbender Mapbender 2.4.4

Mapbender Mapbender 2.4.5 rc1


不受影响的程序版本

Mapbender Mapbender 2.4.5 rc1


漏洞讨论

Mapbender is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.



Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.



Versions prior to Mapbender 2.4.5 rc1 are vulnerable.


漏洞利用

Attackers can use a browser to exploit this issue.



The following proof-of-concept URI is available:



http://www.example.com/php/mod_gazetteer_edit.php?gaz= 1 LIMIT 0 UNION(SELECT char(65), char(65), char(65), char(65), char(65), char(65),mb_user_name, char(65), mb_user_password, char(65) from mb_userLIMIT 0,1)


解决方案

The vendor released Mapbender 2.4.5 rc1 to address this issue. Please see the references for more information.







Mapbender Mapbender 2.4.4


相关参考

本文标题:CVE-2008-0301-漏洞详情
本文链接:
(转载请附上本文链接)
http://vulsee.com/archives/vulsee_2019/0713_2906.html
转载请附本站链接,未经允许不得转载,,谢谢:微慑信息网-VulSee.com » CVE-2008-0301-漏洞详情
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

微慑信息网 专注工匠精神

访问我们联系我们