微慑信息网

firefox安装未验证及旧扩展插件的解决办法

1、使用firefox版本<57的办法:

hackbar:

firefox+hackbar增强版下载

依然在about:config中,设置“extensions.legacy.enabled”为true;如果该值本身为true,则设置为false,然后再设置为true,此时,选择从文件从安装:

参考:https://www.ghacks.net/2017/08/12/how-to-enable-legacy-extensions-in-firefox-57/

2、对验证未签名的插件,将原xpi文件,解压后,修改“install.rdf”文件,里面的 <em:id>、<em:name> 都改成别的,<em:maxVersion> 也改成 别的,然后压缩成zip,最后改名为xpi,

然后登陆:https://addons.mozilla.org/zh-CN/developers/addon/submit/upload-unlisted

进行版本上传

成功进行签名,下载安装即可

 

其中在提交xpi的时候,可能会有些问题,根据提示修改即可:

参考:

https://kreen.org/1847/how-to-use-unsigned-extentions-on-firefox

https://bbs.kafan.cn/thread-2052440-1-1.html

https://www.cnblogs.com/TIlifeng/p/5385742.html

3、刚刚在t00ls上看到,有推荐使用waterfox:

https://www.waterfoxproject.org/en-US/

Waterfox是一个纯64位版的火狐浏览器,它使用Firefox官方源码,专门为64位Windows操作系统优化编译而成。新版基于Firefox 36.0.4正式版构建,Waterfox内置了最新Flash、Java和Silverlight插件的64位版本。支持任何官方火狐支持的扩展。

确实OK,安装中不存在是否验证、新旧的问题..

 

本文标题:firefox安装未验证及旧扩展插件的解决办法
本文链接:
(转载请附上本文链接)
http://vulsee.com/archives/vulsee_2018/1211_7226.html
转载请附本站链接,未经允许不得转载,,谢谢:微慑信息网-VulSee.com » firefox安装未验证及旧扩展插件的解决办法
分享到: 更多 (0)

评论 抢沙发

评论前必须登录!

 

微慑信息网 专注工匠精神

访问我们联系我们