微慑信息网

【漏洞通告】32位Redis 远程代码执行漏洞(CVE-2021-32761)

2021年7月22日,阿里云应急响应中心监测到Redis官方发布公告,披露了CVE-2021-32761 Redis(32位)远程代码执行漏洞。

01

漏洞描述

Redis是世界范围内应用广泛的内存型高速键值对数据库。2021年7月21日Redis官方发布公告,披露了CVE-2021-32761 32位Redis远程代码执行漏洞。在32位Redis中,攻击者在Redis存在未授权访问的情况下可利用*BIT*命令与proto-max-bulk-len配置参数可能造成整形溢出,最终导致远程代码执行。目前尚未有相关脚本流出,且漏洞仅影响32位Redis,阿里云应急响应中心提醒 Redis 用户尽快采取安全措施阻止漏洞攻击。 

02

漏洞评级

CVE-2021-32761 Redis(32位)远程代码执行漏洞 高危

漏洞细节 漏洞PoC 漏洞EXP 在野利用
未公开 未公开 未公开 未知

04
03
03

影响版本

Redis >2.2 且 < 5.0.13

Redis >2.2 且 < 6.0.15

Redis >2.2 且 < 6.2.5

05

安全版本

Redis 5.0.13

Redis 6.0.15

Redis 6.2.5

06

安全建议

1、根据影响及其安全版本排查并升级到安全版本,或使用64位Redis

2、若暂无法升级,可通过启用Redis身份认证,禁止未授权用户调用*BIT*命令以及CONFIG SET指令

 

07

相关链接

https://github.com/redis/redis/security/advisories/GHSA-8wxq-j7rp-g8wj

 

 

原文始发于微信公众号(阿里云应急响应):【漏洞通告】32位Redis 远程代码执行漏洞(CVE-2021-32761)

本文标题:【漏洞通告】32位Redis 远程代码执行漏洞(CVE-2021-32761)
本文链接:
(转载请附上本文链接)
http://vulsee.com/archives/vulsee_2021/0722_14736.html
转载请附本站链接,未经允许不得转载,,谢谢:微慑信息网-VulSee.com » 【漏洞通告】32位Redis 远程代码执行漏洞(CVE-2021-32761)
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

微慑信息网 专注工匠精神

访问我们联系我们