微慑信息网

CVE-2008-1350-漏洞详情

CVE-2008-1350
CVSS 7.5
发布时间 :2008-03-17 12:44:00
修订时间 :2008-09-05 17:37:30
NMCOE    

[原文]SQL injection vulnerability in kb.php in Fully Modded phpBB (phpbbfm) 80220 allows remote attackers to execute arbitrary SQL commands via the k parameter in an article action.


[CNNVD]Fully Modded PHPBB2 ‘kb.php’ SQL注入漏洞(CNNVD-200803-243)

        Fully Modded PHPBB2是一款基于PHP的论坛程序。


        PHPBB2在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞执行SQL注入攻击。


        如果将mode设置为article且设置了page_num的话,Fully Modded PHPBB2的kb.php文件没有正确地验证k参数便将其用到了SQL查询中,这允许攻击者通过提交特制的SQL查询请求执行SQL注入攻击。成功攻击可能允许攻击者检索管理员用户名和口令哈希,但要求知道数据库表前缀。


        


CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]


CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]


CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用


OVAL (用于检测的技术细节)

未找到相关OVAL定义


官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1350

(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-1350

(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200803-243

(官方数据源) CNNVD


其它链接及资源

http://www.securityfocus.com/bid/28225


(UNKNOWN)  BID  28225
http://www.securityfocus.com/archive/1/archive/1/489468/100/0/threaded


(UNKNOWN)  BUGTRAQ  20080312 Powered by phpBB 2001, 2006 (SQL)
http://www.milw0rm.com/exploits/5243


(UNKNOWN)  MILW0RM  5243
http://secunia.com/advisories/29339


(VENDOR_ADVISORY)  SECUNIA  29339
http://xforce.iss.net/xforce/xfdb/41192


(UNKNOWN)  XF  phpbb-kb-sql-injection(41192)
http://securityreason.com/securityalert/3745


(UNKNOWN)  SREASON  3745


漏洞信息

Fully Modded PHPBB2 ‘kb.php’ SQL注入漏洞
高危 SQL注入
2008-03-17 00:00:00 2008-09-05 00:00:00
远程  
        Fully Modded PHPBB2是一款基于PHP的论坛程序。


        PHPBB2在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞执行SQL注入攻击。


        如果将mode设置为article且设置了page_num的话,Fully Modded PHPBB2的kb.php文件没有正确地验证k参数便将其用到了SQL查询中,这允许攻击者通过提交特制的SQL查询请求执行SQL注入攻击。成功攻击可能允许攻击者检索管理员用户名和口令哈希,但要求知道数据库表前缀。


        


公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:


        http://phpbbfm.net/support/index_fm.php


漏洞信息 (5243)

Fully Modded phpBB (kb.php) Remote SQL Injection Vulnerability
(EDBID:5243)
php webapps
2008-03-12 Verified
0 TurkishWarriorr

N/A

[点击下载]


漏洞信息


42875
Fully Modded phpBB kb.php k Parameter SQL Injection

Remote / Network Access

Information Disclosure,
Input Manipulation
Loss of Confidentiality,
Loss of Integrity
Solution Unknown
Exploit Public Uncoordinated Disclosure


漏洞描述

Fully Modded phpBB contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'kb.php' script not properly sanitizing user-supplied input to the 'k' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.


时间线


2008-03-12

Unknow
2008-03-12 Unknow


解决方案

本文标题:CVE-2008-1350-漏洞详情
本文链接:
(转载请附上本文链接)
http://vulsee.com/archives/vulsee_2019/0713_3338.html
转载请附本站链接,未经允许不得转载,,谢谢:微慑信息网-VulSee.com » CVE-2008-1350-漏洞详情
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

微慑信息网 专注工匠精神

访问我们联系我们